[olug] Printing issues and connecting for updates at openSuSE

Thomas D. Williamson twilliam at inebraska.com
Wed Dec 19 02:05:12 UTC 2012

I decided to move to KDE with a new installation of openSuSE 12.2,  
everything seems to have gone fine. So when I set up my printer,  
through a server, I tried to do it like my other SuSE Linux  
boxes/laptops. I could not get it to recognize it through ldp like the  
others, but it did find it with an App Socket, and Yast told me it was  
communicating with the printer. Only no test pages would print, I can  
ping the print server, but when I looked at the error message it said:  
"Unable to write print data Broken pipe."

I looked through the CUPS error log and there was a regular appearing  
line: "Unable to connect to @LOCAL on port 631."

I checked the CUPS config file through the web interface, and it does  
have the line to open port 631.

Now the print server does use port 515 and I set the port at the IP  
address, in Yast.

I am not sure what to do to get the 631 port open to allow the print  
to get through.

Another issue I have run into is that when there is a update that  
looks to the openSuSE site, the whole thing times out and fails. I  
tried to go to the site and get it downloaded directly, but it did not  
seem to complete the download. When I tried to use what I downloaded  
the installer gave me a error message, that it was not a file the  
installer could use. This happened with the CUPS update file and the  
glibc update file. There are some other updates that were pushed  
today, and only those that did not look at the openSuSE site were able  
to update.

I tried to download the source for CUPS and then build the rpm to see  
if that would fix my problems, but there were files not installed, and  
when I tried to get those to do that one was a glibc, which failed to  

Any ideas or suggestions on either of these issues?


Tom Williamson

This message was sent using IMP, the Internet Messaging Program.

More information about the OLUG mailing list