[olug] dhcpcd problem

Tanya Loughead tanyaloughead at cox.net
Thu Apr 25 15:17:47 UTC 2002

Thanks everyone for trying to help me.  To better describe my problem, AND
what I have already tried to fix the problem, my UNIX-mentor suggested that
I describe my problem in a more "exacting"  manner..... So, these are his
words-- Sorry that it's so long.  I'm so grateful for your time and help.  I
solemnly hereby swear to always help other struggling Linux users, if I ever
get to the point of knowing what the heck is going on!
So, here it is:
Problem: connecting to the Internet via Cox cable. DHCP is the
recommended protocol in Windows and Mac documentation provided
by Cox, yet what appears to be a correct Linux setup for DHCP
fails to yield proper network assignments of address, gateway
or DNS servers.

Configuration: recent Dell laptop, PIII 128 with a Xircom 10/100/modem
combo PCMCIA, running unpatched Redhat 7.2. The kernel recognizes
the card and I can plumb the interface as eth0 manually with
ifconfig(8). Network options are set in /etc/sysconfig/network to
enable the interface at boot, DHCP is enabled, all according to
Redhat support documents. Normal runlevel is 3; loopback fails
initialization. Not sure if/what correct rc scripts for DHCP are
run or linked at all in /etc/rc3.d/. Make/model of cable "modem"
unknown.  No samba configured.

Checked: Installation was re-done to ensure DHCP was chosen and
configured to be used. Apparently netcfg is no longer part of redhat?
The card is recognized by the stock kernel and the PCMCIA HowTo
bears this out, although some (unknown if relevant) Xircom bugs
have been fixed in more recent kernels. The link light activates
on both the card and the modem.  dhcpcd(8) run by hand generates
traffic for about a minute - debug output shows timeouts and tx/rx
lights on card do activate during negotiation. The command exits
with 14.

A crossover cable and straight-through cat-5 have both been tried,
each time directly to the modem. A Win98 machine, similarly configured,
successfully initalizes its network using the same physical
configuration (via the straight ethernet cable) and DHCP. Lastly,
the "-r" flag was passed to dhcpcd to check for use of obsolete
DHCP protocol - nothing, but it did exit with 0 and leave a dummy
DHCP reserved net configured (169...). dhcpcd used without flags
(or -d) result in an RFC 1917 assignment (192.168.100) to the
interface, but no gateway is set. The Win98 machine when it initializes
gets a real net, address and gateway starting with 68.

I'm hoping that I just haven't done the right dance to properly get
DHCP to work. I don't think I can completely eliminate the card
based on the above tests, but it would be quite unusual to have it
work only half-way. Normally I use NAT with a fixed addresses on
both sides, so I am unfamiliar with what I *had* understood to be
a pretty straightforward setup with DHCP.

> -----Original Message-----
> From: Brian Roberson [mailto:roberson at olug.org]
> Sent: Wednesday, April 24, 2002 11:22 PM
> To: olug at olug.org
> Subject: Re: [olug] dhcpcd problem
> the #1 thing to check is.....
> is the driver properly loading into the kernel? here are a few
> key commands:
> "lsmod "
> ( list modeules...  look for your net card driver... trivial, but
> necisary )
> ifconfig -a
> ( if you dont know the module name for your NIC, this will tell
> you that you
> have SOMETHING loaded... you should see an interface named eth0 )
> In redhat, there are quite a few gui's to get your nic setup... I
> will let a
> redhat user walk you through those, of course once we determine
> if your nic
> is setup at the lowest layer or not.....
> On Wednesday 24 April 2002 09:41 pm, Tanya Loughead wrote:
> ....
> -_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
> For help contact olug-help at olug.org - run by ezmlm
> to unsubscribe, send mail to olug-unsubscribe at olug.org
> or `mail olug-unsubscribe at olug.org < /dev/null`
> (c)1998-2002 OLUG http://www.olug.org
> -_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_


For help contact olug-help at olug.org - run by ezmlm
to unsubscribe, send mail to olug-unsubscribe at olug.org
or `mail olug-unsubscribe at olug.org < /dev/null`
(c)1998-2002 OLUG http://www.olug.org


More information about the OLUG mailing list