[olug] can't get eth0 up

Vincent vraffensberger at home.com
Sun Aug 13 01:35:41 UTC 2000

ktb wrote:
> I sent this to the redhat list and haven't had a response, thought I'd try
> you guys.  I'm using redhat 6.2 in console only.  The short of it is I
> upgraded to the 2.2.15 kernel and since then I can't get my eth0 to work.
> I'm now using my old kernel and things are still broke.
> _________________________________________________________
> OK I reverted back to my default kernel and eth0 is still broken since I
> recompiled a new kernel.  I got depmod to work by blowing away everything
> that was in /etc/modules.conf and leaving it blank.
> Then I tried: insmod /lib/modules/2.2.14-5.0/net/ne2k-pci.o
> Got the following errors:
> unresolved symbol ei_open
> unresolved symbol ethdev_init
> unresolved symbol ei_interrupt
> unresolved symbol NS8390_init
> unresolved symbol ei_close
> If I try: modprobe -a net \* it runs for a while and then freezes the
> keyboard and everything and I have to hard reboot.
> Anyone know what is going on here?
> Thanks,
> kent
> ---------------------------------------------------------------------

I don't have a real answer without some more info, but I can list a few
things to check or try.

Look for any conflicts or anything else unusual in these files:


Have you tried compiling it into the ketnel instead of loading it as a
module?  I've always thought that something like a network card which is
always in use should be compiled into it anyway.

Did you do `make modules ; make modules_install` after `make bzImage` ? 
...or did you do the rpm thing?

To unsubscribe, e-mail: olug-unsubscribe at bstc.net
For additional commands, e-mail: olug-help at bstc.net

More information about the OLUG mailing list