[olug] Fedora 17, XFCE fails to start Xorg - solved

Kevin D. Snodgrass kdsnodgrass at yahoo.com
Sat Jun 2 14:39:19 UTC 2012

----- Original Message -----

> From: Jon Larsen <jon at jonlarsen.us>
> To: Kevin D. Snodgrass <kdsnodgrass at yahoo.com>; Omaha Linux User Group <olug at olug.org>
> Cc: 
> Sent: Friday, June 1, 2012 6:46 AM
> Subject: Re: [olug] Fedora 17, XFCE fails to start Xorg
> I remember reading somewhere that there is a bug in Nouveau for older 
> nvidia cards.  I'm trying to find the reference, but I cannot find it. 
> I believe it was on planet.fedoraproject.org.  Maybe it was fedoraforum.org.
> You may need to wait for a nouveau/kernel update.

Problem was the install created an /etc/X11/xorg.conf file that loaded "vesa" instead of "nouveau".  Changing /etc/X11/xorg.conf to this:
Section "Device"
    Identifier "Videocard0"
#  Driver "vesa"
    Driver "nouveau"

Fixed the problem.

Now F17 looks good and the screen registration problem is mostly gone too. YAY!
(On F13, F15 and Ubuntu 10.10/11.04/11.10/12.04LTS the screen is shifted left and down and the mouse pointer is also off by the same number of pixels.  Works correctly now.  This is NOT a screen issue, since the other 2 machines on this monitor work flawlessly via the KVM.)

On a side note, after this fix I ran yum update, 145 updates on the base install for something that just came out Tuesday...

Now if I can just get grub2 to behave...

Kevin D. Snodgrass 

More information about the OLUG mailing list