[olug] Dig +search question...

Obi-Wan obiwan at jedi.com
Wed Apr 4 01:48:55 UTC 2012

> I'm trying to setup a quick BIND9 DNS server for my internal home network
> using Ubuntu 11.10 Bind9 packages.
> When I run *"dig @localhost titan"* on my DNS server, I don't get an IP
> address. When I run *"dig @localhost titan.linder.corp"* I get the answer I
> expect.
> Did this change, or has dig always worked like that?  I am fairly certain a
> have run "dig _shortname_" and it worked correctly...

My own home setup works just as you describe.  I can't say that I
remember it ever working differently.  The DNS server runs on a
CentOS 4 box.  I ran the dig command from a Fedora 16 box.

Ben "Obi-Wan" Hollingsworth    obiwan at jedi.com    PrairieRimImages.com
   The stuff of earth competes for the allegiance I owe only to the
     Giver of all good things, so if I stand, let me stand on the
       promise that You will pull me through.  -- Rich Mullins

More information about the OLUG mailing list