[olug] Compaq laptop pcmcia wireless network setup

Don Doumakes doumakes at loganet.net
Wed Sep 7 01:12:41 UTC 2005

I've just reinstalled Gentoo on my laptop, which seemed like a good idea
at the time.  Now I can't get the wireless card to see any access
points, though it worked before.  I could use some help from a wireless
guru, or from somebody who has a similar configuration working.

(hoary old) Compaq Armada 7800
Netgear PCMCIA wireless card, MA521 (RealTek 8190 chipset)
Gentoo Linux from 2005.1 liveCD
kernel 2.6.12-gentoo-r6
wireless-tools version 27
rtl8180 version 0.21-r1
Modules r8180, ieee80211_r8180, ieee80211_crypt_r8180 are all loaded.

When I run "/etc/init.d/net.wlan0 start" the output is:

 * Starting wlan0
 *   Configuring wireless network for wlan0
 *     no access points found
 *   Couldn't find any access points on wlan0
 *   Failed to configure wireless for wlan0

I've attempted this in several locations with access points, so I'm
convinced the problem is on the laptop rather than on the access points
I tried to use.  I could be wrong about that I suppose.  I don't have my
own access point to experiment with.

I've saved all files from /etc before I did the reinstall, so if it
would help to know about an old version of /etc/whatever, I do have that

Any clues would be appreciated.

Don Doumakes

More information about the OLUG mailing list