[olug] Partition issues...

Miller, Scott L (Omaha Networks) scott.l.miller at hp.com
Sun Jun 13 03:57:54 UTC 2004

Hi all,

I've got a 60GB disk where, ignoring all good engineering principles,
I've got every important partition created for my Mandrake 9.1 system.
I originally started with a 12 Gig main partition, 1 Gig swap (1 Gig
Ram), 1.5 Gig log area, ~5 Gig home and ~13 Gig VMWare (other OS stuff).
Plus I originally had approximately 10 gig NTFS partition.  All this
added up to about 40 gig used.

I recently decided the NTFS partition, which had a Win2k partion that
was old, and apparently crippled, had to go; My tool of choice diskdrake
(which I'm nearly certain has been responsible for creating everything
on this drive). I wiped that partition out, and then attempted to create
a new ext3 partition that would use the remaining 26 or so Gig. And then
proceded to attempt to backup some stuff from a different harddrive's
partition on to this new area.  But, things weren't right.  'df' claimed
the new partition only had 9 gig available.  Diskdrake claimed it had 26
Gig. The 'cp' process died after filling that 9 gig.  Back in Diskdrake
I started playing around, I tried resizing it.  Resizing STARTED at 9
gig and only allowed a downward movement.  WTF?

Ok, so I resized that guy as large as resize allowed.  I figured I'd
just make yet another partition.  Finished the resize, the data
survived, started creating another new partition.  That's when things
got worse.  I could not create hda9 no matter what I tried.

So, I started searching and reading and playing with other partition
programs.  The best set of Partition Table output I've been able to get
is the following: 

                                         cfdisk 2.11x

                                     Disk Drive: /dev/hda
                               Size: 61492838400 bytes, 61.4 GB
                     Heads: 255   Sectors per Track: 63   Cylinders:
    Name           Flags        Part Type    FS Type             [Label]
Size (MB)
    hda1           Boot          Primary     Linux ext3
    hda5                         Logical     Linux swap
    hda6                         Logical     Linux ext3
    hda7                         Logical     Linux ext3
    hda3                         Primary     Linux ext3
    hda8                         Logical     Linux ext3
                                 Pri/Log     Free Space

Partition Table for /dev/hda

            First    Last
 # Type     Sector   Sector   Offset  Length   Filesystem Type (ID)
-- ------- -------- --------- ------ --------- ----------------------
 1 Primary        0 25061399      63 25061400  Linux (83)
Boot (80)
 2 Primary 25061400 84517964       0 59456565  Extended (05)
None (00)
 5 Logical 25061400 27712124      63  2650725  Linux swap (82)
None (00)
 6 Logical 27712125 30555629      63  2843505  Linux (83)
None (00)
 7 Logical 30555630 39905459      63  9349830  Linux (83)
None (00)
 3 Primary 39905460 65432744       0 25527285  Linux (83)
None (00)
 8 Logical 65432745 84517964      63 19085220  Linux (83)
None (00)
   Pri/Log 84517965 120101939       0 35583975  Free Space
None (00)

So, I've got the bootable primary on hda1, that's good. Hda2 is an
extended partition, over sectors 25M to 84.5M, OK. I've got logical
partitions for hda5,6,7 and 8, and they're all within the extended
partition's range of sectors (hda8 being the new "resized" partition
mentioned earlier); that's good too. But WHY is hda3 a primary partition
AND stuck in the middle of the extended partition's sector range?!?!

And this still doesn't explain why I can't create another partition.
>From what I've read, the limit is 4 primary partitions, and (as I
understand) only one of those can be and extended partition.

Anyone have any ideas of how to fix or get around the partition issues
so I can use the last 18 gig available on this drive before I resign
myself to backing this whole mess up and starting over?

-Scott L. Miller

More information about the OLUG mailing list