[olug] Chronic Sound Issue

Jake Churchill jachurchill at cox.net
Wed Dec 15 00:38:34 UTC 2004

I have a chronic sound issue with SuSE 9.1 and my audigy card. I have
tried Mandrake 10 also and seem to have the same problem but with older
versions did not.

Whenever I log into kde the sound does not work. I researched and found
that if I ran alsaconf as root it would configure everything. But as
soon as the X-server restarts the sound is gone. Even if I just log out
and log back in it will be gone (I think this restarts the X-server

I did some more research and found that alsa will store the sound card
setup to /etc/asound.state. So I ran alsaconf as root and got my sound
working. Then I ran alsactl store 0 (my sound card is 0) and it stored
all the settings to this file. Everything was working fine and then I
logged out and it happened again. However, now I just have to run
alsactl restore 0 and it will restore my sound.

Coming from my OS X background, I'd like this to just happen
automatically. I have researched the modules that are loaded and upon
starting the system the emu10k1 module is there and after running
alsaconf it is still there. I don't understand why sound would be tied
to user preferences somehow rather than the system. I found somewhere in
YaST once a way to turn off loading the OSS sound driver because I
thought they might be conflicting. This didn't work either. 

When I go through YaST to try to setup the sound module it gets about
half way through and errors out and this will totally screw my sound
over and I'll have to run alsaconf as root again.

So, bottom line I have no idea what the problem might be. I just want it
so when I log in I don't have to run alsaconf as root or alsactl restore
0. It's easy but it's annoying and there's got to be something that can
change it.

More information about the OLUG mailing list