[OLUG] NIC Purgatory

Paul T. McNally nally at radiks.net
Wed Feb 23 00:33:42 UTC 2000

I have 2 network cards that are SMC1211TX EZCard 10/100 PCI cards.
>From what I have read off the net they are NE2000 clones. When I install

RedHat 6.1, the card at eth0 is recognized and initiallized OK. Here are
lines from dmesg:

rtl8139.c:v1.07 5/6/99 Donald Becker
eth0: SMC1211TX EZCard 10/100 (RealTek RTL8139) at 0xa400, IRQ 5,

When I rebuild the kernel, eth0 fails to initialize. I've tried many
times the last I
tried to use many of the driver options offered in the Config file.
Luckily the installation
kernel comes with a smp kernel and a non-smp kernel. As a note for the
it takes almost 6 minutes to compile a kernel using both processors and
takes almost 12 minutes to compile a kernel using only one processor.

I suspect I'll need to specify:

0xa400, IRQ 5, 00:e0:29:46:fa:c2

in lilo.conf so the kernel gets the specs on my network cards. I have no
where or how to do that.

Also I have the other card at eth1 so what would I need in lilo.conf so
card gets initialized as well.

Also when RedHat 6.1 is installed, I suspect much of the IP
is by default not selected including ip_masquerading and ip_chains. Is
correct? The machine I am rebuilding is on a dsl line and I want to put
up a
firewall and use ip masquerading amongst other things. Plus I like to
an optimized kernel.


I don't feel like I am in NIC hell but I don't think this would qualify
NIC heaven thus NIC purgatory.

Sent by OLUG Mailing list Manager, run by ezmlm.  http://olug.bstc.net/ 
To unsubscribe: `echo unsubsribe | mail olug-unsubscribe at bstc.net` 

More information about the OLUG mailing list